Запись логических формул в Excel

Excel — отличный числовой редактор, на основе которого удаётся создавать уникальные сводные отчёты, сопровождаемые важными математическими, логическими, аналитическими действиями.

Если научится самостоятельно создавать нужные логические формулы в Excel, то выполнение многих производственных задач будет впоследствии сопровождаться чрезвычайной лёгкостью, быстротой и безусловной точностью.

Логические формулы в Еxcel

Основные операции

Создание формулы в Excel не сопровождается особыми сложностями, если пользователь полноценно освоит некоторые азы работы с табличным редактором. Начинать изучение этого офисного приложения лучше всего с тех вычислительных примеров, которые являются самыми простыми и максимально распространёнными. Это позволит понять суть и важные правила работы с табличным редактором.

Освоив простейшие азы, можно приступать к созданию логических формул.

Ведение простейших подсчётов

Для начала работы следует запустить само офисное приложение. Далее важно определиться, что должно посчитаться автоматически. Чаще всего к работе приступают, когда уже имеется числовая информация, на основе которой приходится осуществлять множественные операции при помощи калькулятора. Теперь эту счётную машинку нужно отложить в сторону и полностью довериться электронной таблице.

Запись любого числового выражения совершается со знака «=». Не выставив его, Excel воспримет введённый запрос, как текстовую запись, отобразит её, но не осуществить подсчёт.

Часто необходимо не просто осуществлять подсчёты, используя данные в таблице, а проводить анализ, сопровождаемый несколькими условиями. Опять-таки всё это проделывать самостоятельно вручную неразумно, когда имеются такие уникальные возможности Excel, способной выполнять любые требования пользователя.

В категории «Логические» самой распространённой является функция ЕСЛИ. Эта функция рассматривает предложенные варианты, а далее определяет, выполняется это условие или нет. Результат функции ЕСЛИ зависит от того, что в итоге желает видеть пользователь. А для того чтобы результат правильно отображался, следует знать, как задать условие в Excel.

Функция ЕСЛИ состоит из трёх аргументов:

  • логического (основного) выражения (требование, которое пользователь желает проверить в таблице);
  • значения, отображающегося, если условие будет полностью соблюдаться;
  • значения, если заданное требование не выдерживается.

Итак, можно попробовать создать простейшую вычислительную таблицу, взяв за основу пример, где главной будет логическая функция ЕСЛИ.

Создание логической формулы

В частности, в ячейку А1 ввести числовой показатель «5», а в ячейку А2 показатель «8». Если пользователю необходимо сравнить два показателя и выдать автоматический итог произведённых действий, составляется выражение, которое, безусловно, начинается со знака «равно»: =ЕСЛИ(А1>А2; «Больше»; «Меньше»). После введения этой записи в любую свободную ячейку, нажатия Enter, в ней сразу будет демонстрироваться ответ. Если пользователь заменит значения в А1 или А2, то ответ также автоматически перестроится.

В тех случаях, когда важно выявить несовпадение двух показателей, введённых в соседние столбцы, первоначально нужно вникнуть, как в Excel правильно записать условие неравно, после чего создать запрос, используя логические функции. Знак «неравно» в Excel обозначается двумя операторами — «<>». Соответственно, нужно записать так: =ЕСЛИ(А1<>А2; «Значения разные»; «Значения одинаковые»).

Составление функций с несколькими условиями

После того как пользователю удалось задать несколько простых логических функций, можно переходить к более сложным вариантам, когда создаётся функция ЕСЛИ в Excel с несколькими условиями.

Условное форматирование ячеек

Создать логические формулы, в которых должно проверяться не одно требование, а сразу несколько, в электронной таблице также можно. Для этого применяются ещё дополнительные функции, среди которых распространёнными является функция «И» (требует обязательного выполнения заданных критериев), «ИЛИ» (допускает частичное выполнение требований).

Результат выполнения, состоящих из нескольких критериев, может отображаться в числовом виде, текстовом, а также «подсвечиваться» заданными цветовыми оттенками, что позволяет мгновенно выявить значения, которые так важны тому, кто анализирует данные.

Для того чтобы создать электронную таблицу, которая будет не просто выдавать результат, а сопровождать выполнение критериев различными цветовыми оттенками, следует разобраться, как закрасить ячейку в Excel по условию.

Закрасить определённую область таблицы будет несложно, если пользователь полностью понял принцип, как задать выражение, рассматривающее одновременно два требования.

Например, пользователю важно, чтобы А4 приобрела зелёный фон при условии, что сумма значений, введённых в А1 и А2 будет равна 5, а в А3 значение будет равно 8, в противном случае А4 должна закраситься красным цветом.

Если бы нужно было просто задать такую формулу с несколькими требованиями, то она выглядела бы так: =ЕСЛИ(И(СУММ(A1:A2)=5;А3=8);ИСТИНА;ЛОЖЬ). Вводя такую формулу в А4, нажав Enter, мгновенно отобразится либо «истина», если условие выполняется, либо «ложь».

Когда же нужно вывести не текстовый ответ, а закрасить ячейку в нужный цвет, необходимо кликнуть по А4, сделав её активной, после чего зайти в «Формат», перейти на строку «Условное форматирование», в открывшемся окне выбрать из раскрывающегося списка строку «формула», ввести в открывшуюся чистую строку созданную ранее формулу в таком виде: =И(СУММ(A1:A2)=5;А3=8). Теперь следует кликнуть по кнопке «Формат», откроется новое окно, где можно выбирать, как должна измениться А4, если будет выполняться требование. На вкладке «Вид» выбирается цвет заливки ячейки при выполнении требования.

Итак, научиться создавать логические формулы, сопровождаемые несколькими условиями, можно, если проявить усидчивость, скопировать готовые примеры, рассмотреть их на новом листе электронной таблице, после чего составит несколько подобных. Освоив логические формулы, электронная таблица Excel понравится ещё больше, поскольку она будет облегчать выполнение многих задач.

  • ВКонтакте
  • facebook
  • обычная форма
  • Оставить комментарий

сети
программы
Smart TV
ос
не нашли ответ?

Задайте вопрос нам!